MediaWiki

Ако си инсталирате МедияУики, софтуера на Уикипедия, и след като приключи инсталацията се покаже тази грешка:

Warning: domdocument::domdocument() expects at least 1 parameter, 0 given in includesparserPreprocessor_DOM.php on line 574

Fatal error: Call to undefined method domdocument::loadXML() in includesparserPreprocessor_DOM.php on line 576

във конфигурационния файл LocalSettings.php добавете следното:

$wgParserConf = array(
‘class’ => ‘Parser’,
‘preprocessorClass’ => ‘Preprocessor_Hash’,
);

има го описано в МедияЗила. Проблемът май се появява само при инсталиране на текущата разработвана в Subversion версия.

  • проблемът е наличен при инсталации върху Windows и в наскоро излязлата версия 1.13.0, въпреки че пише, че е оправен. 👿 Пуснах бележка и го отворих за доразглеждане.

  • проблемът е наличен при инсталации върху Windows и в наскоро излязлата версия 1.13.0, въпреки че пише, че е оправен. 👿 Пуснах бележка и го отворих за доразглеждане.